
ATM meres:

Meresi kornyezet:
1 PC (Windows NT)
1 ATM protokoll analizator (vendor Wandel & Goltermann, type DA30)
1 ATM kapcsolo (type Alcatel 7470 multiservice platform)
Hasznalando programok: 

Hyperterminal (version 690170)
ATM Analyzis Application (version 3.0.0.18)

Osszekotes:



Elso lepesek:
1. feher hosszabbito bekapcsolasa (asztal alatt)
2. ATM kapcsolo bekapcsolasa

a. PS1 kar felhuzasa (ON allapotba)
b. PS2 kar felhuzasa (ON allapotba)
c. Feed A bekapcsolasa (ON allapotba)
d. Feed B bekapcsolasa (ON allapotba)

3. PC bekapcsolasa (Windows NT valasztasa a boot menuben, ez a default  tehat ne valasszuk a VGA 
modot)
4. (ATM analizator be van dugva, igy bekapcsol amikor a hosszabbitot bekapcsoljuk)

PC inditasa utan:
pcre valo bejelentkezeshez:
ctrl+alt+del

login fulnel:
name: user
password: nincs jelszo, uresen kell hagyni

(kozben nem gond ha hibauzenetet kapunk – at least one service or driver failed... Egyszeruen csak 
OKzuk le)

A meres elkezdesehez meg kell varni amig az ATM kapcsolon az STM12 IR, STM12 MMF, ... status 
es active ledek zolden vilagitanak (ez 45 perc kb az ATM kapcsolo elinditasa utan)

Feladatok:
(Kepek mentesere egy lehetseges megoldas a Print screen billenyu lenyomasa, majd a Paint programba 
be lehet illeszteni es elmenteni a kepet  ha nem jelenik meg beillesztes utan a kep, akkor a bal oldali 
menuben a legalso ket nagy ikon kozul kattintsunk a felsore.)

1. Delay measurement 
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Subtask 1 (10 points without help, 6 points with help): How can we create PVCs? How can 
we get the list of PVCs? 

Asztalrol newbridge.ht ikonra kattintva (vagy Programs>Accessories>Hyperterminal>
newbridge.ht) el kell inditani a hyperterminalt!

ENTERT kell nyomni, miutan bejott a program!
Utana:
Enter level: 5
Enter Password: mainstreet

PVC letrehozasa:
PVCt a config menu connect almenujeben lehet csinalni, meg kell adni a ket vegpontot, 
amelyek kozott letrejon a PVC.



Tehat:
Confighoz 1est kell megnyomni, utana bejon az almenu, itt a Connecthez a 3ast kell 
megnyomni, majd be kell irni az egyik vegpontot:
(Forma: ShelfSlotPort;VPI/VCI)
Irjuk be: P161;101/102
ENTER

Meg kell adni a masik vegpontot, ezt az almenu Toendpoint valasztassal adhatjuk meg, azaz a 
3ast kell megnyomni, majd irjuk be:
P141;101/102
ENTER
Ezutan meg kell erositeni a kapcsolatot (proceed), a 0ast kell lenyomni.

Savszelesseget is be lehet allitani, ezt a TrafficBidirRates menupontban lehet megadni, tehat 
Traffichoz az 5ost kell lenyomni, Bidirhez 3ast, Rateshez 4est, majd az 1est, es be kell irni 
mondjuk 101k t (ENTER, majd 0 a proceedhez)

CANCELlel lepkedhetunk vissza egy almenubol egy hozza kepest fomenube, tehat 8as gomb. 
Ezt most haromszor kell megcsinalni a PVCk kilistazahoz.

PVCk kilistazasa:
PVCk kilistazasa: (config>connect>) show group, azaz 1es gomb lenyomasa.
Itt lathato az altalunk letrehozott PVC, es meg jo par. (Page downnal es Page uppal lehet le es 
fel barangolni a PVC listaban, azaz a 2es, illetve 6os lenyomasaval.)

CANCELlel (8as) ki lehet lepni.
Ha megint lenyomjuk a CANCELT, akkor ujra be kell irni egy PVC vegpontot (P161;101/102 
es lathatjuk hogy ott van meg).

Ha 9est nyomunk (QUIT), akkor kilepunk a configconnect menubol. (a letrehozott PVC 
termeszetesen megmarad)

Az alabbi pontban lehet megnezni milyen Slotok vannak:
config(1es)Show slots(6os).
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Subtask 2 (10 points without help, 6 points with help): How can we generate traffic with a 
protocol analyzer into a specific PVC (How can we generate cells with a specific VPI and 
VCI value using a protocol analyzer)? How can we capture the departure times of 
generated traffic? In the ``user emulation" mode what is conveyed in the Rx and Tx 
direction? 

Analizator program elinditasa:
Asztalrol az ATMStandard ikonra kattintva elindul a program.
(vagy Programs>Acterna DominoNAS>DominoNAS Components>ATM Analysis 
Application)



Create a new configuration>Next
Ekkor lathatjuk, hogy nem ismeri fel a program az analizatort. Ekkor csukjuk be a programot, 
majd a talca jobb oldalan van egy kis ikon (3 csik egymason – ha az egeret odahuzzuk, kiirja 
hogy Acterna Analyzer Server (Idle)). 
Erre jobb klikk>reset, majd OK. Ujra jobb klikk az ikonra ha vegzett, es view. Ha ekkor sem 
jelenik meg, akkor:
Programs>Acterna DominoNAS>DominoNAS Components>Domino Core Tools>
Gigabit Flash loader elinditasa. Varjunk egy kicsit, majd zarjuk be az ablakot ami megjelent 
(nem baj hogy meg mindig waitinget ir ki). 

Most reseteljuk ujra az analizatort.
Jobb klikk az ikonra es view, majd lathatjuk hogy megjelent az analizator. Ezt bezarhatjuk.
(Denest is megkerdeztem, ezt sajnos mashogy nem lehet, igazabol ezt o mutatta meg. Masik  
lehetoseg, ha a prokoll analizatort mindig bekapcsolva hagyjuk, ekkor felismeri a program a PC 
ujra bekapcsolasa utan is,  ha mar 1x beallitottuk.  Harmadik lehetoseg,  es  talan ez  lenne a  
legjobb: meres elott mi beallitjuk ezt es akkor a hallgatonak nem kell ezzel foglakoznia. Ekkor 
persze   mar   bekapcsolt   allapotban   kell   lennie   az   analizatornak,   vagyis   a   hosszabbitot  
bekapcsolva hagyjuk es azt a hallgatonak nem kell bekapcsolni.)

Most inditsuk el ujra az ATMStandard(ez csak ikon nev) programot.
Create new...next...next...next...next...next......finish (tulajdonkeppen mindent jova hagyunk)
A harmadik next elott (emulate user mod valasztasa, pontosabban jova hagyasa) latjhatjuk, 
hogy  az analizator Tx1en kuld adatot, de ez megjelenik Rx2n a visszacsatolas miatt, es Rx1
en fogad adatot. Ez a kesobbiekben lesz jo, ha emlekezik ra a hallgato, tovabba ez egy kesobbi 
kerdes is.

Forgalom generalas:
Figyeljuk az also felulet ahol, bal oldalon 5 kis ikon menu van. Itt kattintsunk a harmadikra, 
azaz a transmit ikonra, majd a felulet kozepre jobb klikk.
Tehat jobb klikk>new
name: atm_transmit
Transmit profile type: Atm cells
Call sequence Data Source: Crete a new call sequence
Call sequences data: Add

cell name: atm_cell
VPI: 101
VCI: 102
Tobbi marad ahogy van....OK

Transmission characteristics:
Transmit continuously
Constant Bit Rate: 0.1

Elinditjuk az analizatort a Start gombbal (vagy Setup>Start Analyzer)...
Jobb klikk a letrehozott atm_transmitre>Transmit
Use VPI/VCI from Cell
Varunk egy picit, majd Stop transmit.



Ezzel veget ert a forgalom generalas.

Uzenetek elmentese amiket "elkapott a program":
File>Save Captured Data (.../atm1.cap)

Tx es Rx:
Rx1en erkezik az adat, mig az Rx2 a Tx1rol visszacsatolt  csomag, tehat maga a  kuldott adat.
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Subtask 3 (10 points without help, 6 points with help): Realize the configuration 
illustrated in Figure 1 and measure the switching delay of the switch (switching delay is 
defined as the difference between the generation epoch of a cell and the arrival time of the 
same cell which is looped back). Arrows in Figure 1 illustrate a PVC which should be 
created and looped back with an optical cable. The protocol analyzer injects cells into this 
PVC. Cells are carried by this PVC through the switch and return back to the analyzer. 
The departure and arrival times can be captured by the protocol analyzer for the analysis. 

Az elfogott es lementett adatforgalom megnyitasa:

File>Examine

Itt kivalasztjuk a korabban elmentett fajlt, megnyitjuk. A bejovo ablakban megkereshetjuk a  
kuldott(Rx2) es bejovo(Rx1) csomagokat (a beallitott VPI/VCI ertekbol tudhatjuk meg hogy 
hol kezdodnek).

Switching delay merese:
A kapcsolasi  kesleltetes  100 ms,   legalabb   is  ez   fordul  elo  a   legtobb esetben  a  delta   time  
oszlopban (Rx1).

Miutan  megmertuk,   zarjuk  be   az   acterna   examine  programot,   es   allitsuk   le   az   analizator  
programot is a STOP gombbal.

2 Usage Parameter Control
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Subtask 1 (10 points without help, 6 points with help): How can we set the GCRA 
parameters to PVC?

A hyperterminalban kell beallitani a trafficbidirservice catconstant rate opciot (felteve ha mar 
a configconnectben vagyunk  ha nem lepjunk be es irjunk is be egy PVC vegpontot amit 
korabban is).
Tehat 5, 3, 1, 1 majd 0 a proceedhez.

Utana a BidirRatesPeak0+1 almenuben kell beallitani 100kt.
Tehat egy CANCEL (8as), majd 4, 1 es 100k, majd ENTER es proceed.

Ezutan az analizer programban a Transmit parameternel at kell allitani konstans bit ratet 200k
ra mondjuk.
Jobb klikk az analizator program atm_transmit profile namere, majd edit.
Utana next>next>next es a 0.1 Mbit/s at kell irni 0.2re.



Subtask 2 (10 points without help, 6 points with help): Generate traffic (CBR) and check 
the impact of GCRA parameters on the discarding rate of generated cells?

Elinditjuk az analizatort a Start gombbal (vagy Setup>Start Analyzer)...
Az elozo feladat beallitasai utan jobb klikk atm_transmit profile namere, majd transmit....
varunk...stop transmit. 
Majd file>save captured data, utana examinebol nyissuk meg.

Latszik, hogy a kuldott cellak fele elveszett. (Rx1 csak 2 darab Rx2 utan van, tehat minden  
elkuldott csomagbol (Rx2)  pontosabban cellabol  elveszik egy mert a savszelesseg fele az  
adasi sebessegnek)

De amugy mar az examine megnyitasa elott is latszik, hogy a cellak fele elveszik. Transmitnal 
(adasnal) latszik az analyzer program felso feleben, a jobb oldali feluleten, az ATM fulnel.  
Tehat a Filtered felirat alatti Cell countnal az Rx2 kb. duplaja Rx1nek. (Amikor meg peldaul 
0.1 Mbit/s volt az adasi sebesseg, akkor megegyezett a ket ertek.)

Miutan elemztuk az uzeneteket,  zarjuk be az acterna  examine programot,  es allitsuk  le  az  
analizator programot is a STOP gombbal.

3  SVC call generation
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Subtask 1 (10 points without help, 6 points with help): How can the ATM address of the 
ATM switch be configured? How can we list the ATM address of the switch?

Az ATM switch ATM cime a kovetkezokeppen allithato be:
Config(1)>SVC(2)>System(5)>Addr_Prefix(1)>ATM_and_addr(2)
Itt be lehet irni ertekeket, pl.: a123 vagy a124...

Kiiratni az ATM cimet (az elobbi lepesekkel, csak most nem irjuk at):
Config(1)>SVC(2)>System(5)>Addr_Prefix(1)
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Subtask 2 (10 points without help, 6 points with help): How can we make the SVC call 
from the analyzer?

Azt, hogy hogyan lehet SVC hivast veghez vinni a kovetkezo alfeladatba irtam, mert ott kell  
ilyen hivast generalni. De ahhoz, hogy generalni tudjunk:
Letre kell hozni egy uj elofizetot a hyperterminal programmal. Ez a kovetkezokeppen megy:
Ha kell akkor lepkedjunk vissza CANCEL(8) parancsokkal vagy QUIT(9) paranccsal
Config(1) > SVC(2) > Call_proc(1) > Subscriber(1)
Irjuk be:
e122 ENTER (proceed  0) (vagy e123,...vagy ami meg nincs, vagy torolni kell minden meres 
elott azt amit megadunk a diakoknak, hogy hozzanak letre)
Utana Location(4) t is meg kell adni:  P161;TG0 (proceed  0)
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Subtask 3 (10 points without help, 6 points with help): Generate SVC calls with the use of 
the protocol analyzer! Capture signalling messages which are exchanged between the 
protocol analyzer and the switch! Measure the call setup time! Suggestion: in order to do 
it ATM address should be assigned to the protocol analyzer and the protocol analyzer 
should be configured as the caller and called party at the same time.

SVC hivas:
Az also feluleten a telefon ikonra kattintunk (call setups), majd jobb klikk a feluleten:
New>adunk   profil   nevet:   atm_call>pointtopoint>Calling   party   number   bepipal>
kivalasztjuk a Public E.164 tipust es beirjuk az e122 uj letrehozott felhasznaloszamot a network 
mezobe (azaz 122), mind a called mind a calling party resznel.
Utana pedig mindenre next, majd finish.

Elinditjuk az analizatort az analizator programban a "play" gombbal. 

Majd jobb klikk az atm_call profile namere es setup call (lehet repeatelni is, de eleg egy is...
OK). 

Uzenetjelek elfogasa es megnyitasa:
File>Save captured data (pl.: atm_call.cap)
File>Examine
Ebben lathatoak a hivas uzenetek az Interpretation oszlopban:

Signaling UNI 3.X (ATM) RX1 Call Proceeding...
...
Signaling UNI 3.X (ATM) RX2 Connect Call_Reference...
Signaling UNI 3.X (ATM) RX1 Connect Acknowledge...
...

A call setup time pedig leolvashato az analizator program Channel Discovery feluleterol a 
Setup time oszlopbol es a User sorbol. (nekem pl. 119 ms)

Az utolso lepesek:
1. Miutan elmentette a meresrol a jegyzokonyvet, allitsa le az analizatort a stop gombbal, zarjon be 
minden alkalmazast.
2. Kapcsolja ki a PCt.
3. Kapcsolja le az analizatort

a. Feed B kikapcsolasa (OFF allapotba)
b. Feed A kikapcsolasa (OFF allapotba)
c. PS2 kar lehuzasa (OFF allapotba)
d. PS1 kar lehuzasa (OFF allapotba)

4. Feher hosszabbito kikapcsolasa.


